Crypto withdrawals delays on the Ethereum network
Resolved·Degraded performance

The performance of the Crypto withdrawal functionality has been restored.

Tue, Feb 10, 2026, 07:26 AM
(1 day ago)
·
Affected components
Updates

Resolved

The performance of the Crypto withdrawal functionality has been restored.

Tue, Feb 10, 2026, 07:26 AM

Identified

We are experiencing some delays for Crypto withdrawals on the Ethereum network due to a spike in the gas fees. We are actively monitoring the situation.

Mon, Feb 9, 2026, 09:16 PM(10 hours earlier)
Powered by