Resolved
The performance of the Crypto withdrawal functionality has been restored.
Resolved
The performance of the Crypto withdrawal functionality has been restored.
Identified
We are experiencing some delays for Crypto withdrawals on the Ethereum network due to a spike in the gas fees. We are actively monitoring the situation.