The performance of the Crypto withdrawal functionality has been restored.
Thu, Feb 12, 2026, 04:05 PM
(2 months ago)
·
Affected components
Updates
Resolved
The performance of the Crypto withdrawal functionality has been restored.
Thu, Feb 12, 2026, 04:05 PM
Identified
We are experiencing delays for Crypto withdrawals on the Ethereum network due to a recent spike in the gas fees. We are actively monitoring the situation.
Thu, Feb 12, 2026, 01:49 PM(2 hours earlier)
Crypto withdrawals delays on the Ethereum network - Naewe Status